Directory

Open Source Packages

Libraries, frameworks, tools, and SDKs used by the apps in this directory — scored the same way as the apps themselves.

5929 packages

All Packages

83Health
Library npm

otplib

TypeScript-first TOTP and HOTP library with a pluggable crypto/base32 architecture for Node, Bun, Deno, and browsers.

2,290
MIT
Used by 22
69Health
Library npm

OTPAuth

HOTP and TOTP one-time password library for Node.js, Deno, Bun, and browsers

1,482
MIT
Used by 15
93Health
Library Composer

phpseclib

Pure-PHP implementations of SSH2, SFTP, X.509, RSA, AES, and dozens of other cryptographic primitives

5,593
MIT
Used by 6
45Health
Library npm

speakeasy

A Node.js library for generating and verifying RFC 4226 (HOTP) and RFC 6238 (TOTP) one-time passcodes for two-factor authentication.

2,753
MIT
Used by 5
71Health
Library Composer

Google2FA

A framework-agnostic PHP implementation of HOTP and TOTP one-time passwords, compatible with Google Authenticator and similar apps.

2,010
MIT
Used by 4
86Health
Library npm

@node-rs/argon2

Native Rust binding for Argon2 password hashing in Node.js

1,470
MIT
Used by 4
75Health
Library Composer

Firebase php-jwt

A simple PHP library to encode and decode JSON Web Tokens conforming to the JWT spec.

9,808
BSD 3
Used by 2
89Health
Library Composer

lcobucci/jwt

A simple, RFC 7519-compliant PHP library for creating, signing, and validating JSON Web Tokens

7,478
BSD 3
Used by 2
46Health
Library Composer

Laravel Hashids

A Laravel service provider and facade bridge for the Hashids library, encoding integers into short reversible hash strings.

2,055
MIT
Used by 2
66Health
Library Composer

OTPHP

A PHP library for generating TOTP and HOTP one-time passwords per RFC 4226 and RFC 6238

1,492
MIT
Used by 2
38Health
SDK npm

node-acme-client

A simple, unopinionated Node.js client for the ACME protocol, automating certificate issuance from Let's Encrypt and other CAs.

295
MIT
Used by 2
48Health
Library Composer

random_compat

PHP 5 polyfill for PHP 7's cryptographically secure random_bytes() and random_int()

8,150
MIT
Used by 1
55Health
Library npm

react-native-keychain

Secure, cross-platform credential storage for React Native apps using native Keychain and Keystore.

3,479
MIT
Used by 1
61Health
Library Composer

Sodium Compat

Pure PHP polyfill for the libsodium cryptography extension

932
Other
Used by 1
45Health
Library npm

crypto-hash

Tiny isomorphic hashing module that uses the native crypto API in Node.js and the browser.

645
MIT
Used by 1
78Health
Library npm

better-sqlite3-multiple-ciphers

Synchronous SQLite3 driver for Node.js, forked from better-sqlite3, with built-in multi-cipher database encryption support.

242
MIT
Used by 1

Join founders buildingwith open source

Opinionated takes, migration guides, cost-saving tips, and insights from the open source ecosystem.

Subscribe on Substack
Join 750+ subscribers